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內容大綱
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本單元介紹網絡分析的重要概念，主要以犯罪網絡為示
範說明對象，相關演算及製圖技術則以UCINET軟體為基
礎，希望拋磚引玉，引發興趣，共同合作，教學相長

主要大綱
1. 定義與應用
2. UCINET安裝與介面
3. 社會網絡資料與暗黑網絡分析
4. 全網絡指標及其應用
5. 次級團體指標及應用
6. 個體網絡指標及應用
7. 網絡的統計推論



定 義

社會網絡：由社會行動者間關係所集合的結構

網絡：點與連線的集合

社會網絡分析：以社會行動者互動為分析對象

的觀點(perspective)或途徑
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發展歷史
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心理學

• 1930年代的格式塔心理學發現社會構型對心理與行動的影響，
衍生諸如社群圖、平衡、圖論、凝聚力等概念

哈佛學派

•霍桑實驗研究成果推論出諸如非正式組織、派系、社群等概
念

曼徹斯特學派

•1950年代研究變遷與矛盾的人類學研究，發展出全網絡、子
網絡、自我中心網絡、密度、可達性、結構、角色、互惠性
等概念

新哈佛學派

•運用數學方法，分析社會結構，奠定社會網絡分析發展基礎，
開發諸如區塊模型、弱連結、鑲嵌、人情等方法與概念

急速成長期

• 1990年代後，拜資訊科技進展，社會網絡分析邁入急速發展
期，同時也發展出更具特色的理論概念，諸如結構洞、社會
資本，進而建立專業的學術團體與期刊



社會網絡分析的特色

 聚焦社會關係，契合當代社群互動生活
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• 跨領域的理論來源，分析技術急速進步

• 重視經驗數據，可融合質化分析與直覺

• 強調圖形表達，依賴數學與計算機演算

• 能結合機器學習、資料探勘與文字探勘



多元領域的應用
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社會 人類學 農業 能源 環境

地理 運輸 數學 經濟 生態

公衛 組織 市場 物理 政治

傳播 統計 資訊 …..



網絡概念的詮釋力

 社會網絡分析作為一種觀點或途徑

 當代社會是網絡社會，網絡社會特徵可用來詮釋更多
社會現象

 社會網絡分析可以彌補當前社會研究的不足，建立網
絡概念典範

 實用需求激增，例如犯罪分析，並與資料科學結合
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無可迴避的研究途徑

 在過去三十年裡，經驗性的社會研究被抽樣調查所主
導。一般的情況是，透過對個人的隨機抽樣，調查變
成了一個社會學的絞肉機─將個人從他的社會背景中
撕裂，並確保研究中沒有任何人與人的互動影響。這
有點像一位生物學家將實驗動物經過碎肉機的處理後，
利用顯微鏡在一百個中挑出一個細胞來觀察；這裡，
解剖學與生理學派不上用場，結構與功能消失，剩下
的只有細胞生物學‧‧‧如果我們的目的是理解人類
的行為而不只是記錄它，我們最先需要瞭解的是群體、
鄰里、組織、社交團體、社區，以及互動、溝通、角
色期望、社會控制。

 __Allen Baton, 1968
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The 911 drew attention from governments for the 

use of SNA as a tool for understanding dark network  

 Valdis Krebs, 2001, Mapping Networks of Terrorist Cells. 

Connections 24(3): 43-52.





UCINET軟體
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 載點：
https://sites.google.com/site/ucinetsoftware/downloads

 32-bit version為宜，軟體會經常更新

https://sites.google.com/site/ucinetsoftware/downloads


UCINET的demo檔
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 安裝後，在文件夾中會生成<UCINET data>檔案夾，內
含可練習的網絡資料，該檔案夾也是UCINET系統預設
的檔案儲存夾

 若文件夾中沒有找到，請到C碟的<Analytic 

Technologies>中找<Datafiles>

 以下是經常使用的示範檔，KNOKBUR.##d、
KNOKBUR.##h (Indianapolis市十個組織的兩種關係，
Knoke and Kuklinski, 1982)



教材定位與自定預設檔案夾
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以下簡稱教材



UCINET的檔案格式

 一個UCINET檔案同時有二種格式

 .##h檔案格式：讀取時只讀取.##h檔

 .##d檔案格式：永遠伴隨在.##h檔而行

 以上二個檔是以文字檔所構成，一般稱作資料語言(DL，
data language)

 以Excel所建立的資料必須透過UCINET讀取儲存才會成為
DL檔案(.##h與.##d)

 由於UCINET資料有二個格式檔，下載時必須同時放在
一個位置，同時檢查格式(.##h與.##d)是否完整，是
否變成亂碼



 利用UCINET中的矩陣編輯讀取<NOKBUR.##h>資料

 UCINET矩陣編輯>File>Open，該檔有二個網絡資料

矩陣製表
UCINET的矩陣編輯讀取UCI格式的網絡資料



NetDraw 介紹
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NETDRAW製圖

 NETDRAW右側諸功能可做點、線、網絡的不同呈現

 NETDRAW >Properties可調整圖形的點、線、箭頭、文字數
據、背景之呈現方式(含顏色、形狀、大小)

 NETDRAW >Layout可利用各種方式與演算法執行節點配布
與圖形位置調整
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NETDRAW的圖形與資料存檔

 網絡圖檔儲存jpg

 網絡圖轉為UCINET檔，連
線為1/0時為二值圖，連線
有正常數值為數值圖

 網絡圖轉為Vna檔，Vna檔
可直接由NETDRAW讀取
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社會網絡資料_Network Boundary
 Realist(實在論)

 The network exists as a social entity
 For example, policy insiders recognized by themselves
 But who are the key players?

 Nominalist(唯名論)
 The network is based on a priori framework constituted by analyst’s 

theoretical concerns
 For example, a list of specialists who publish papers
 Need to justify the boundary chosen

 Combination: 
 不須視為對立，且可以併用。例如，先從犯罪資料鎖定網絡
邊界進行瞭解，再對個別行動者徵詢其與其他組織成員的互
動類型



How to access relational data

 A general sampling does not work for SNA 

 Ego networks (自我網絡):

 Focusing on a set of egos and surveying their ties with alters (相鄰
者) and between alters

 The average size of individuals’ core discussion networks dropped from 2.94 to 

2.08 (McPherson, Smith-Lovin, and Brashears, 2006 )

 Complete networks (全網絡)

 A more common approach

 Defined by case studies



資料結構差異
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•傳統屬性資料

•網絡資料

傳統資料用於摘錄行動者的屬性，網絡資料專注行動者間的關係



Types of Social network data

參考教材第一~三章

 Symmetric One-Mode Networks

 對稱+單模網絡

 File>Open>PADGETT.##h  (15世紀義大利佛羅倫薩家族九
種關係中的婚姻關係，Padgett and Ansell, 1993)



Types of Social network data

 Asymmetric one-mode networks

 不對稱+單模網絡

 File>Open>Krack-High-Tec.##h  (矽谷高科技公司管理者的
諮詢關係，Krackhardt, 1992)



Types of Social network data
 Two-Mode Networks (affiliation networks 隸屬網絡)

 What has been different?

 File>Open>davis.##h  (美國南方18位婦女參加14項活動的情形，Davis  

et.al. 1941)



Darkness of dark network?

 百分之九十的情報是從公開資料來的

 The real intelligence hero is Sherlock Holmes, not James Bond

 例如，911直前，發現蓋達(Al-Qaeda)與Liberia, Sierra 
Leone, Bukiena Faso的鑽石交易往來密切。這是因為國際
銀行已經阻絕蓋達的經援進出，因此這些地區內的軍
閥成為蓋達獲取武器與金錢重要來源

 啟示：對犯罪、偵防網絡資料，不須對其隱匿性抱持
過度憂心，仍與偵查的經驗、方法、技術、及敏銳度
有關



Collecting social network data
 Questionnaire

 可用於治安或社區安全調查

 Interviews
 最佳，但難度高，需輔以其他方式

 Direct observation
 be ware of Hawthorne effect, but useful in applying two-mode network

data for criminal studies

 Written records
 結合內容分析、文字與資料探勘，如判決書

 Other approaches
 Cognitive social structure (CSS) data: asking respondents for their

perceptios of other actors’ network ties (每一受訪者提供一張全員
互動矩陣表格，分析時整合所有受訪者的矩陣)



Questionnaires

 從關係(類型?正負面?)掌握行動者(數量?)及其互動內容與頻率(程度)，
另依需要增設項目，但考慮項目的實用性與精確性(清楚否)

 Roster: 由研究者提供所有行動者清冊供指認

 Free recall: 由受訪者自由指認

 Fixed choice: 指定受訪者應指認的數目 (some risks of misleading)

 Tie rating(頻率): either dichotomous or valued (the latter becomes difficult as the
network size increases )

以關係指認行動者 互動頻率互動類型 互動媒介



Types of dyadic ties commonly studied

Category Varieties and examples

Co-occurences Co-membership in groups, co-participation in 

events, physical distance, similarities in 

attributes (e. g., political views)

Social relations Kinship, affection, perception

Interactions Transactions, activities

flows Ideas, information, goods, infections



網絡分析使用三種資料結構 參考教材第六章
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相鄰矩陣 行動者A 行動者B 行動者C

行動者A 0 1 5

行動者B 0 0 1000

行動者C 1 1 0

隸屬矩陣 個體屬性 群組屬性 網絡個體指標 網絡群組指標 事件

行動者A 1 1 0.88 0.55 1

行動者B 0 2 0.22 0.44 0

行動者C 1 1 0.1 0.23 1

關聯矩陣 事件1 事件2 事件3

行動者A 1 1

行動者B 1 1

行動者C 1 1

屬性資料

矩陣資料

可轉化為
矩陣資料



矩陣表格的數據類型 參考教材第五章

A B

A 0 1

B 1 0

A B

A - 1

B 0 -

A B

A 1 1

B 1 0

A B

A 0 5

B 0 0

二值無向(binary & undirected)

無向=對稱

數值有向(valued & directed)二值+自我連結(binary & self-tied)

二值有向(binary & directed)

有向=不對稱

excel輸入時，專注數值輸入，最後就 0值與對角，利用<取代>加上 0 



利用excel檔建立網絡與屬性資料

2017_net_1.xlsx

2017_att.xlsx



 利用UCINET中的矩陣編輯讀取.xls資料，轉存為
UCINET檔

一般以EXCEL建立資料後再轉換為UCINET檔



再利用UCINET的矩陣編輯讀取.##h資料

 進行相關演算與製圖前，執行此一步驟以確保資料
讀取正確
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檢視二個UCINET檔



NetDraw 的網絡圖製作 參考教材第四章
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加入個體屬性資料



製圖結果



利害關係人的jpg檔



Method and strategy in tracking dark networks

 網絡圖的直覺觀察容易聚焦大節點，並以為這是網絡分
析的主要重點，當運用於犯罪偵查及預防，便容易單純
導向打擊與斬首策略

 注意：應該以策略引導方法，而非以方法引導策略;  
However, the tail (method) is often founded wagging the dog 
(strategy).

 As Brafman and Beckstrom (2006) noted, targeting key players in 
decentralized organization seldom shuts them down. Instead, it only 
drives them to become more decentralized, making them harder to 
target.  

 啟示：全網的網絡特徵掌握，仍有助於犯罪偵防與預防
的分析與執行。



Case studies: network topography 

 Terrorist networks with a large number 
of cliques appear to be more effective 
(Pedahur and Perliger, 2006)

 Network density  is positively associated 
with network efficiency (US Army, 
2007)

 Salafi Jihard exhibits the characteristic 
of a scare-free network→a 
strategy→take out hubs rather than 
randomly stopping terrorists at borders 
(Sageman, 2004) [but they were often 
quickly replaced by other highly central 
equivalent actors (Tsvetovat and Carley, 
2005)] 

https://www.openabm.org/book/3

3102/115-scale-free-network

http://wiki.mbalib.com/zh-

tw/Image:800px-Long_tail.png



全網網絡指標 參考教材第八章說明

 規模(size)：the number of actors in a network

 密度(density)：the portion of the potential connections in a 
network that are actual connections

 平均距離(average distance)：average length of all the shortest 
paths (geodesics) between all actors in a network (and the speed 
that [dis]information spreads through a network)

 直徑：a network’s longest geodesic (decentralization)

 破脆度(fragmentation)：the degree to which a network is 
fragmented

 Provincial-cosmopolitan(緊密 vs 鬆散結構)：以密度衡量
 balance=performance (Aristotle 1998)

 Hierarchical-heterarchical(層級 vs 異型結構)：以
Centralization (集中性)測量
 two extreme = underperformmance



Data>Browse:  size and multiplex



Whole network indices



Whole network indices

 數值網計算密度時，必須先將數
值二分(Transform>Dichotomize)成0

與1。

 For symmetric matrices, Centralization 

is Freeman's degree centralization. For 

non-symmetric matrices, Centralization 

is indegree centralization.



次級團體指標 參考教材第十一章

 網絡的中層結構分析，專注子群(=群組=子圖=集群=群體)

 網絡中的聚集常視為具有凝聚力的子群，代表團結，能共
享規範，有一致認同，足以發起集體行動

 除了利用屬性看待行動者的分類，網絡分析更重視利用互
動(link)加以分群
 小團體(clique)：每位成員與其他所有成員都有直接連結，現
實中少見的理想型

 成分(component)：一種對內相連，對外不相連的子圖

 核(core)：K-Core指該子群每位成員與K數目的同組成員有連接

 派系(faction)：利用理想類型評估群體的「派系化」
（factionalization）程度。faction是一種演算法，能尋求最佳方
式將行動者安置於派系中，並與理想類型取得最大相似，檢
測被觀測群組與理想類型有多配適



Brain J Reed, 2006, Formalizing the Informal: A Network Analysis  of the Insurgency, PhD 

dissertation, University of Maryland, p:102 



成分 Component
 使用<UCINET data>中的drugnet.##h (Hartford地區293吸毒者的共用針

具關係，Weeks at al, 2002)

 先用UCINET編輯表單查看drugnet.##h (有向二值)

 UCINET>Network>Regions>Components>Binary graphs，
有向圖選擇<strong components>，無向圖選擇<weak components>

 NETDRAW打開drugnet.##h 後，把 當作attribute輸入NETDRAW



 圖的調整：去除孤立點，改換屬性顏色，拖曳節點，淡化連線顏色，加重節點文
字顏色



NETDRAW操控：孤立,孤懸,MC,Ego,復原

 strong components=? weak components=?

 How do we explain the formation of the following strong 

components? 



核 Core 使用PADGETT.##H

聚焦該家族的金錢關係(PADGM)，在

第二種分類中，可以形成七個不同
的核聚集，其中第二集群為2-core群，

占62.5%為最大



PADGM的Core clusters

 注意：高K-CORE巢套(重疊)著低K-CORE5，因此以K-CORE
測定特定人時可能發生錯誤，類似用途最好使用其他分群法



派系Factions

Final proportion correct表

示與理想分類的相似正
確率，此數值愈高愈好

以矩陣做區分，下方有
分割為二派系後的個別

密度

以表單閱讀會更清楚



派系可以圖形顯示，也可以結合其他個體網絡指標，
做進一步分析



指標功能：群組與個體

 Subgroup network index, such as K-CORE,  help us to 
identify clusters that are deeply embedded in particular 
networks and those that are not. Research has shown that 
individuals deeply embedded in networks are unlikely to 
defect.  It will do better to target individuals in the lower 
k-core of the trust and operational networks (Popielarz
and McPherson 1995)

 個體指標為最常用最具直覺效果的指標，在犯罪
網絡分析上，可以用來指認核心人物、觀察組織
運作，以決定打擊策略與時間，實施反間或訊息
戰，發現組織邊緣的低中心性者以防範犯罪組織
的再生或重組



節點的網絡位置 參考教材第十章

 個體權力的解讀：行動者較他人擁有更多連結則
可能佔據有利位置，由於他有許多連結因此可能
有更多替代方式滿足需求，也就減少對他人的依
賴；由於他有許多連結，他可以擁有以及利用網
路資源；由於他有許多連結，他通常在交易中是
協力廠商並促成交易，從而在仲介中獲利



個體網絡指標
 點度中心性(degree centrality)：The number of relations 

which a node has; Divided into outdegree centrality, or the 

number of relations a node is sending to other nodes, and 

indegree centrality, or the number of relations a node is

receiving from other nodes

 接近中心性(closeness centrality)：The total (geodesic )

distance a node is from all other nodes in a network

 中介中心性(betweenness centrality)：A score indicating the 

degree to which a node is on the shortest paths between actors

 UCINET中的中心性也依據上述三類中心性衍生更多不
同的測量方法



UCINET的三類型中心性演算工具

點
度
型

接
近
型

中
介
型





仲介與結構洞 參考教材第九章

 中介中心性已然顯示仲介(broker)角色重要性

 仲介(brokerage): actors are more likely to control the flow of 
resources than others

 Key player  approach: 移除這些仲介者將使網絡瓦解

 弱連結優勢(strength of weak ties): 弱連結往往佔據重要跨
(bridge)位置，發揮網絡連通的關鍵作用(Granovetter 1974)

 結構洞(structural holes): 關注網絡的空隙，主張可以跨接
空隙者，具有將資源有效傳導的機會與力量(Burt 1992)

 結構洞以侷限(constraint)或自主性(autonomy)來計算。每
個節點的三元組(三角連結)，若有缺口就代表該節點擁
有擔任仲介的機會，因此侷限低(自主高)。製圖時，為
方便直覺觀察，將侷限數值賦予負號，如此能以大節
點代表較能掌握結構洞(低侷限)的節點





仲介的不同角色

自我是「仲介」(B)，且與「信源」與「目標」
節點(A 與C)全都同屬於一個群組，此時，B 

在群組中正擔任著「協調人」(coordinator)的
角色

自我 B 在同一群組的二個成員關係間擔任仲

介，但他本身不屬於該群組，他所擔任的是
「顧問」(consultant)角色。

自我 B 擔任的是「守門員」(gatekeeper)角色，
B 是群組成員，並位於群組邊界，控制著外
界(A)連通該組群的路線

自我 B 與A 隸屬同群組，對黑色群組而言，
B 擔任著白色群組的聯絡點或「代表」
(representative)

自我 B 擔任二群組的仲介，但不隸屬任何群
組，這個角色稱作「連絡員」(liaison)。



用來區別每個節點扮演
不同角色的機率



 就drugnet##h製作網絡圖，以drugatte.##h中的
<ethnicity>區分節點顏色，製作圖四張，分別以點度
(in-degree)、接近、中介中心性以及結構洞表達節點大
小



角色對等
 利用角色對等，可以比對犯罪組織類型，也可以協助
發現關鍵人物，或預防犯罪組織的再生

 對等概念：

結構對等

自同構對等 規則對等



網絡統計推論與假設檢定的必要

 網絡生成的解釋與預測

 因果關係的確認

 正負關係的確認

 統計意義的確認

 因素效果的確認

 模型配適的確認



網絡統計
 愈來愈多的社會網絡分析，包含著更多的節點，對於這樣大
型的網絡，已不能單單依賴普查訪問，而必須借重節點的樣
本（samples of nodes）。網絡分析師已瞭解，他們所研究的網

絡會不斷演化，在每個時間點所觀察的關係未必具代表性，
因為這些關係模式並非處於「均衡」狀態。他們已發現，觀
察也會有不可靠的時候──未能記錄下真實發生的關係，或
計算錯了連結強度。以上這些問題（大型網絡、抽樣、觀察
的可靠性）促使社會網絡研究者開始應用描述統計與推論統
計。統計能夠處理大量訊息，將觀察視為機率，而不是社會
過程的決定論式結果。

 然而傳統統計是基於所有觀察項（亦即所有關係）都是獨立
的假定，但網絡分析時許多變項，例如連線，都是由相互依
賴的個體而來的，因此上述假設不成立，傳統統計方法不適
用於網絡分析。網絡統計為前沿技術，一般使用拔靴法、排
列法，以及UCINET無法支援的指數隨機圖模型



UCINET統計工具-1 參考教材第十八章

功能 統計 方法 UCINET操作

描述統計 BN;VN Tools>Univariate statistics

單變數檢定 BN;VN 拔靴法 Network>Compare densities>Against theoretical parameter

檢定二網差異是否顯著 BN1/BN2

VN1/VN2

拔靴法 Network>Compare densities>Paired

檢定(同對偶)二網絡的相
關程度

VN1—VN2 二次指
派程序

Tools>Testing Hypothesis>Dyadic (QAP)>QAP Correlation

檢定(同對偶)二網絡的關
聯程度

BN1—BN2

VN1—VN2
二次指
派程序

Tools>Testing Hypothesis>Dyadic (QAP)>Relational Cross 

Tabs (QAP)

檢定網絡A+網絡B預測
網絡C的顯著性

VN1+VN2+

…→VN9
二次指
派程序

Tools>Testing Hypothesis>Dyadic (QAP)>MR-QAP Linear 

Regression (QAP)

檢定網絡A+屬性B在預
測網絡C的顯著性

BN1+VN2+C

A3+VA4+RA

5…→BN9

二次指
派程序

Tools>Testing Hypothesis>Dyadic (QAP)>LR-QAP Logistic 

Regression (QAP)

檢定屬性A對屬性B的影
響

CA(二
群)→RA

排列法 Tools>Testing Hypothesis>Node-level>T-Test

BN=二值網 ; VN=數值網; CA=類別屬性; VA=數值屬性; RA=關係屬性



UCINET統計工具-2

功能 統計 方法 UCINET操作

檢定屬性A對屬性B的影
響

CA(多
群)→RA

排列法 Tools>Testing Hypothesis>Node-level>Anova

檢定屬性A對屬性B的影
響

CA1+VA2+R

A3+…→RA9

(or VA9)

排列法 Tools>Testing Hypothesis>Node-level>Regression

檢定屬性A對網絡B的影
響是否顯著(卡方)

CA(二
群)→BN

排列法 Tools>Testing Hypothesis>Mixed

Dyadic/Nodal>Categorical attributes>Join-Count

檢定屬性A對網絡B的整
體影響是否顯著

CA(多
群)→BN

排列法 Tools>Testing Hypothesis>Mixed 

Dyadic/Nodal>Categorical attributes>Relational

Contingency Tables analysis

檢定屬性A對網絡B的分
組影響是否顯著

CA(多
群)→BN

排列法 Tools>Testing Hypothesis>Mixed 

Dyadic/Nodal>Categorical attributes>Anova density models

檢定屬性A對網絡B的分
組影響是否顯著

VA( or 

RA)→BN

Moran

/Geary

Tools>Testing Hypothesis>Mixed 

Dyadic/Nodal>Continuous attributes>Moran/Geary 

statistics

Moran (-1~1, 整體性; Geary (<1正, >1負, 地方性)

檢定網絡屬性對網絡(結
構)的預測

P1 改用指數隨機圖模型 ERGM

BN=二值網 ; VN=數值網; CA=類別屬性; VA=數值屬性; RA=關係屬性



示範
LR-QAP Logistic Regression (QAP)

 網絡：drugnet##h

 屬性：drugatte.##h

 檢測模型為：

 Gender(homo)+ethnicity(homo)+drugnet_dc

(constraint)→drugnet



設定

 輸入依變網絡

 輸入獨立網絡

 獨立網絡指定

 網絡效果指定

 變量向量輸入

 變量指定

 變量效果指定

 模型配適輸出

 係數輸出報表



Model fit



變量係數與顯著性
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